Benutzer-Werkzeuge

Webseiten-Werkzeuge


ms_office:excel

Excel

Excel ist die Tabellenkalkulation aus dem Microsoft Office Paket. Das Äquivalent aus LibreOffice heißt Calc.

Zeile/Spalte mit Überschrift immer anzeigen (Excel 2007)

  • Bereich markieren
  • Start→Zellen→Format→Fixieren

Mittelwert ohne Zellen mit Wert 0

Um den den Mittelwert eines Bereiches auszurechnen, in den auch Zellen mit dem Wert 0 stehen, kann man folgende Formeln verwenden:

{=MITTELWERT(WENN(A1:A7<>0;A1:A7))}

Geschweifte Klammern nicht mit eingeben, sondern Formel durch Strg+Shift+Enter abschließen

oder

=SUMMEWENN(A1:A7;"<>0")/ZÄHLENWENN(A1:A7;"<>0")

Import von CSV-Dateien

Über Datei→Öffnen lassen sich CSV-Dateien nur schlecht in Excel importieren, da die Formatierung nicht einstellbar ist/nicht automatisch erkannt wird. Besser ist der Weg über Daten→Aus Text. Dort öffnet sich der Textkonvertierungsassistent, in dem man Trennzeichen und Spaltenformate einstellen kann. Im dritten Schritt unter „Weitere…“ kann auch das Dezimal- bzw. Tausendertrennzeichen von Komma auf Punkt (bzw. umgekehrt) umgestellt werden.

Hoch- oder tiefgestellte Schrift in Legenden

Hoch- oder tiefgestellte Buchstaben in Legenden lassen sich nicht durch die übliche Schriftformatierung erstellen. Bestehen die Hoch-/ bzw. Tiefstellung ausschließlich aus dem folgenden Unicode-Zeichen, lassen sie sich per Copy-And-Paste einfügen.

  • Ziffern und einige mathematische Zeichen ( ⁰ ¹ ² ³ ⁴ ⁵ ⁶ ⁷ ⁸ ⁹ ⁺ ⁻ ⁼ ⁽ ⁾ ₀ ₁ ₂ ₃ ₄ ₅ ₆ ₇ ₈ ₉ ₊ ₋ ₌ ₍ ₎ )
  • vollständiges Alphabet (außer q) hochgestellter Kleinbuchstaben ( ᵃ ᵇ ᶜ ᵈ ᵉ ᶠ ᵍ ʰ ⁱ ʲ ᵏ ˡ ᵐ ⁿ ᵒ ᵖ ʳ ˢ ᵗ ᵘ ᵛ ʷ ˣ ʸ ᶻ )
  • hochgestellte Großbuchstaben ohne C, F, Q, S, X, Y, Z ( ᴬ ᴮ ᴰ ᴱ ᴳ ᴴ ᴵ ᴶ ᴷ ᴸ ᴹ ᴺ ᴼ ᴾ ᴿ ᵀ ᵁ ⱽ ᵂ )
  • einige tiefgestellte Kleinbuchstaben ( ₐ ₑ ₕ ᵢ ₖ ₗ ₘ ₙ ₒ ₚ ᵣ ₛ ₜ ᵤ ᵥ ₓ )
  • einige griechische Buchstaben ( ᵅ ᵝ ᵞ ᵟ ᵋ ᶿ ᶥ ᶲ ᵠ ᵡ ᵦ ᵧ ᵨ ᵩ ᵪ ).

Sortieren nach Zeile

Standardmäßig sortiert Excel immer nach Spalten. Unter Daten→Sortieren→Optionen kann die Sortierrichtung auf „Zeilen sortieren“ eingestellt werden.

Datenzugriff mit VLOOKUP bzw. SVERWEIS

Mit der Funktion VLOOKUP bzw. SVERWEIS in der deutschen Version kann Anhand eines Schlüssels oder einer ID auf die Daten einer anderen Tabelle zugegriffen werden. Die zweite Tabelle kann auch eine andere Exceldatei sein. Die Daten in der ersten Tabelle sind eine Verknüpfung, so dass sie aktualisiert werden, wenn die Quelle sich ändert. Ist dies nicht gewünscht kann man unter Daten → Verbindungen → Verknüpfung bearbeiten die Verknüpfung löschen und gerade aktuellen Daten in die erste Tabelle kopieren.

Spalte automatisch füllen

Um eine Spalte automatisch mit einer Formal oder einem fortlaufenden Wert zu füllen, kann man den ersten Wert eintragen und doppelt auf das kleine schwarze Rechteck am Markierungsrahmen klicken. Alternativ mit mit der Tastenkobination Strg + Shift + Pfeil runter die Spalte markieren und dann Strg + D füllen.

Rechnen mit Zeit und Datum

Das Rechnen mit Zeiten und Daten in Excel ist gewöhnungsbedürftig. Grundsätzlich sind alle Zeiten und Daten Dezimalwerte. Lediglich zur Anzeige wird der Wert in ein Zeit- oder Datumsformat (Zellenformat „Zeit“ oder „Datum“) umgewandelt. Zum Debugging kann es hilfreich sich die Dezimalwerte anzusehen (Zellenformat „Numerisch“). Negative Zeiten („01:00 - 02:00“) sind standardmäßig nicht erlaubt. Um mit ihnen rechnen zu können, kann unter anderem das Datumsformat 1904 eingestellt werden: Datei → Einstellungen → Erweitert → 1904-Datumwerte verwenden. Soll eine Differenz gebildet werden, die über die Taggrenze von 24 Stunden hinausgeht (23:00-01:00, gewünschtes Ergebnis 02:00), wird teilweise eine Formel wie

=A2-A1+(A1>A2)

empfohlen. Das funktioniert für die Anzeige. Zugrunde liegt aber eine negative Dezimalzahl, die beim Weiterrechnen damit zu unerwarteten Ergebnissen führt. Besser ist:

=MOD(A2-A1;1)

Hier liegt eine positive Dezimalzahl zugrunde, die sich beim Weiterrechnen wie erwartet verhält. Soll eine Zeit größer als 24 Stunden dargestellt werden muss, das benutzerdefinierte Format [hh]:mm:ss oder ähnlich (wichtig sind die eckigen Klammern) zugewiesen werden. Für Hilfe zur Syntax oder zum Testen von benutzerdefinierten Zellformaten eignet sich https://customformats.com/.

Microsekunden abtrennen

Hat man eine Zeit wie 12:30:12.123 und möchte die Mikrosekunden abtrennen lässt sich dafür am einfachsten die Funtion „Text in Spalten“ verwenden. Dazu das Trennzeichen auf einen Punkt . einstellen.

ms_office/excel.txt · Zuletzt geändert: 2020/06/18 21:08 von olli · Momentan gesperrt von: olli